Jump to content
Sign in to follow this  
Karyl

[FIXED] Remote images/emails

Recommended Posts

This evening, multiple issues were brought to my attention by @Koby:

 

  • Remote image loading appeared broken
  • Some users were not receiving their usual emails (password reset, post notifications, digests [if you enabled that], etc)

 

This issue was due to a configuration error upstream of the website that affected the server's ability to reach the internet - it was not allowing any traffic to flow out of the server to make the above things actually work. As a result, the backend image proxy system cached bad data due to it being unable to reach remote image URLs, breaking all remotely referenced images. On top of this, email system was broken because it was unable to contact DNS to resolve email hostnames.

 

This one was on me, sadly - I was performing some upstream maintenance and left a faulty configuration in place that I had intended to remove. The issue has since been fixed, and emails should be flowing normally again though anything received for the past few weeks, up until tonight, will not be received. Remote image loading should also now function again.

 

I'm sincerely sorry for any inconvenience that caused!

  • Like 2

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...