Jump to content
Sign in to follow this  
Karyl

[FIXED] HTTP->HTTPS automatic redirect broken

Recommended Posts

Good afternoon everyone!

 

A bug was reported to me by @Koby wherein the redirect from http:// to https:// was not occurring automatically as it should have been, instead placing visitors to the http:// version of kametsu.com on a "default" page, the "It works!" page for the entire server.

 

This was caused by a parsing issue with our webserver configuration files where it was not correctly interpreting the settings for the plaintext http:// version - it had believed that there was no configuration for the http:// version of kametsu.com and thus was placing visitors to this on the default configuration host instead of redirecting visitors to the secure https:// version of the site.

 

An updated configuration file was uploaded with a corrected host configuration with a full proper URL defined within +the web server restarted. This appears to have fixed the issue.

 

Moving forward we will likely be employing HSTS rules to force browsers to unconditionally use HTTPS mode by default even when http:// is entered in the address bar, which should help further reduce or even completely eliminate any other possible occurrence of this issue.

 

My apologies for any inconvenience this issue caused!

  • Thanks 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...